Tutorial Mikrotik : Menggabungkan & Menambahkan Koneksi 2 ISP + Failover

shares |

Bagaimana cara menggabungkan sekaligus menambahkan koneksi dari 2 ISP yang berbeda menjadi 1 dan jika salah satu putus link tidak down? Pertanyaan ini lah yang akan kita cari jawabannya dan kita ulas di Tutorial Mikrotik Indonesia kali ini.

Pada Tutorial Mikrotik kali ini, saya menggunakan 2 koneksi Internet dari 2 ISP yang berbeda.
ISP 1 = Three mobile broadband (USB Modem) --> port usb1
IP Address : Dynamic

ISP 2 = Telkomsel Flash (Android Tethering) --> port wlan1
IP Address : 192.168.43.1

Perangkat yang saya gunakan adalah Mikrotik RB751U-2HND. Perangkat ini memiliki 5 Port ethernet, 1 wlan, dan 1 port USB. Ketiga port ini akan kita gunakan untuk membangun sistem Dual ISP + Failover.

Disini saya coba menggunakan USB Modem sebagai koneksi ke ISP Three, dan wlan1 untuk koneksi dari HP Android ke ISP Telkomsel. Jika anda ingin menggunakan port ethernet saja atau port lainnya silakan dapat Anda sesuaikan sendiri setingan di tutorial ini.

Interface yang digunakan :
1. ppp-out --> koneksi ke ISP1
2. wlan1 --> koneksi ke ISP 2
3. ether2 --> koneksi ke client

Langsung saja ke Tutorial Mikrotik : Menggabungkan & Menambahkan Koneksi 2 ISP + Failover berikut ini :

1. Sebelum mulai, saya sarankan untuk me-reset Mikrotik Anda ke konfigurasi awal, agar tidak terjadi error setelah konfigurasi.
2. Masuk ke Mikrotik via Winbox --> Aktifkan interface wlan1 dan ppp-out.
3. Setting ppp-out dengan konfigurasi :
- Name : TRI
- APN : 3 data
- Phone : *99#
- username : 3data
- password : 3data
4. Setting wlan1 koneksikan dengan Android Tethering --> ganti nama wlan1 menjadi TSEL.
5. Buat DHCP Client untuk wlan1 (TSEL) --> IP --> DHCP Client --> Add
6. Tambahkan IP Address untuk ether2
7. Buat DHCP Server untuk ether2
8. Buat Mangle dengan script berikut. Silakan sesuaikan dengan nama interface yang anda gunakan :
/ip firewall mangle
add action=mark-connection chain=input in-interface=TSEL new-connection-mark=\
    ISP2_Conn
add action=mark-connection chain=input in-interface=TRI new-connection-mark=\
    ISP1_Conn
add action=mark-routing chain=output connection-mark=ISP1_Conn \
    new-routing-mark=to_ISP1 passthrough=no
add action=mark-routing chain=output connection-mark=ISP2_Conn \
    new-routing-mark=to_ISP2 passthrough=no
add chain=prerouting dst-address=10.85.187.58 in-interface=ether2
add chain=prerouting dst-address=192.168.43.0/24 in-interface=ether2
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=ether2 new-connection-mark=ISP1_conn \
    per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=ether2 new-connection-mark=ISP2_conn \
    per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=ISP1_conn \
    in-interface=ether2 new-routing-mark=to_ISP1
add action=mark-routing chain=prerouting connection-mark=ISP2_conn \
    in-interface=ether2 new-routing-mark=to_ISP2
9. Buat NAT untuk kedua ISP tersebut dengan Script berikut :
/ip firewall nat
add action=masquerade chain=srcnat comment="NAT ISP1" \
    out-interface=TRI
add action=masquerade chain=srcnat comment="NAT ISP2" \
    out-interface=TSEL

10. Buat Route kedua ISP untuk Failover :
/ip route
add check-gateway=ping distance=1 gateway=TRI routing-mark=to_ISP1
add check-gateway=ping distance=1 gateway=192.168.43.1 routing-mark=to_ISP2
add check-gateway=ping distance=1 gateway=TSEL
add check-gateway=ping distance=1 gateway=TRI

11. Setingan Selesai. Coba koneksi dengan bandwidth test menggunakan speedtest.net.
 

12. Coba download test menggunakan IDM.


Bagi anda yang masih bingung dengan Tutorial Mikrotik ini, silakan lihat Video Tutorial Mikrotik : Menggabungkan & Menambahkan Koneksi 2 ISP + Failover berikut ini :

Baca Tutorial Mikrotik Lainnya

9 comments:

  1. permisi mas, saya mau tanya..ini apakah dua-duanya aktif atau hanya salah satu saja..jd misalnya isp pertama down, baru ISP kedua aktif..
    apakah ini bisa diterapkan ke jaringan internet dan intranet yg tergabung jd satu di mikrotik, jd misalnya 1 PC, selain untuk internetan juga bisa mengakses intranet dalam waktu bersamaan??terima kasih sebelumnya..

    ReplyDelete
  2. saya telah mencoba tutorial diatas menggunakna 2 koneksi Lan sebagai gateway, tetapi mikrotik hanya menggunakan 1 gateway saja yang aktif, bagaimana mengaktifkan 2 gateway bersamaan ? terimakasih

    ReplyDelete
  3. Bagaimana jika semuanya menggunakan kabel LAN, misal ISP1 fiber (ip 110.10.10.11), ISP2 optik (ip 220.20.20.22), ether4 ke client (ip 192.168.0.1/24)

    ReplyDelete
  4. SKYNET is a GENSYS

    ReplyDelete
  5. wahh makasih atas infonya sangat membantu saya yang sedang mencari info pengabungan 2 koneksi Internet dari 2 ISP yang berbeda.

    salam kenal http://whussaya.blogspot.co.id/

    ReplyDelete
  6. min, kalo setting 2 hotspot dalam 1 Mikrotik (RB750) apa bisa ya?
    Ether1 = ISP
    Ether2 = LAN
    Ether3 = Hotspot1 (Pakai AP Tp Link-TL WA 5210g) ke Arah SELATAN
    Ether4 = Hotspot2 (Pakai AP Tp Link-TL WA 5210g) ke Arah UTARA
    kalau bisa nanti setting hotspotnya gimana min?
    mohon bantuannya min.

    ReplyDelete
  7. Thanks to mas Rizky, karena sudah berhasil diimplementasikan. Jika boleh request, ada proxy nya juga mas (2isp + failover + proxy). saya coba-coba masih gagal nih

    ReplyDelete

Silakan anda berikan kritik, saran, masukan atau pertanyaan seputar Mikrotik pada kolom Komentar di bawah ini :